Official Ornithe template mod.
Go to file Use this template
Space Walker a26a47bda7 Loom/Ploceus 1.6 2024-04-05 20:12:28 +02:00
gradle/wrapper gradle 8.6 2024-03-19 17:14:41 +01:00
src/main fix mixin 2024-03-19 17:18:24 +01:00
.editorconfig template for 1.3+ using fabric loader 2023-07-17 00:13:32 +02:00
.gitattributes template for 1.3+ using fabric loader 2023-07-17 00:13:32 +02:00
.gitignore template for 1.3+ using fabric loader 2023-07-17 00:13:32 +02:00
LICENSE-TEMPLATE.md template for 1.3+ using fabric loader 2023-07-17 00:13:32 +02:00
README.md update readme 2024-03-19 17:17:46 +01:00
build.gradle Loom/Ploceus 1.6 2024-04-05 20:12:28 +02:00
gradle.properties Loom/Ploceus 1.6 2024-04-05 20:12:28 +02:00
gradlew gradle 8.6 2024-03-19 17:14:41 +01:00
gradlew.bat template for 1.3+ using fabric loader 2023-07-17 00:13:32 +02:00
settings.gradle template for 1.3+ using fabric loader 2023-07-17 00:13:32 +02:00

README.md

Ornithe Template Mod

The official Ornithe template mod. You can use it as a template for your own mods!

Usage

In order to use this mod as a template:

  1. Create a new repository from this template with Use this template
    • Tick the box "Include all branches"
  2. Your repository will contain several branches, each for a different preferred loader and Minecraft version. You can select the appropriate branch as the main branch and discard the others.
    • For Fabric Loader, Minecraft 1.3 and above, use the fabric/merged branch.
    • For Fabric Loader, Minecraft 12w30e and below, use the fabric/split branch.
    • For Quilt Loader, Minecraft 1.3 and above, use the quilt/merged branch.
    • For Quilt Loader, Minecraft 12w30e and below, use the quilt/split branch.
  3. Clone the recently-created repo on your PC
  4. Make the necessary changes in order to make it yours:
    • Update gradle.properties in order to use your
      • Update your mod's Maven group and mod ID
        • If you don't know which Maven group to use, and you are planning to host the mod's source code on GitHub, use io.github.<Your_Username_Here>
      • Update your mod's dependencies
    • Update fabric.mod.json in order to reflect your mod's metadata
      • If you are planning to include (jar-in-jar) a mod, don't forget to declare its dependency on it!
      • The icon provided here is a placeholder one. If you aren't able to replace it yet, you can delete it and remove the "icon" property
    • Create a LICENSE file for this mod! If you don't know which license to use, check out here.
      • If you use LICENSE.md, don't forget to update the buildscript in order to use that file name!
      • In fabric.mod.json, don't forget to put the license's SPDX identifier under the "license" property`.
      • The GPLv3 and AGPLv3 are not valid mod licenses, so you can use almost any license except for those.
    • Update the Java sub-directory structure so it reflects your Maven group
  5. The mod is now ready to be worked on!

License

This template on the OrnitheMC GitHub is licensed under the Creative Common Zero v1.0 license.

Mods created with this template are not automatically licensed under the CC0, and are not required to give any kind of credit back to OrnitheMC for this template.